読者です 読者をやめる 読者になる 読者になる

easy_installやpipでモジュールをインストールする際にマイナーバージョンを範囲で指定する

Python

easy_install(setuptools)やpipでモジュールをインストールする場合にバージョンを指定できるけど、例えばDjangoの1.2系の最新版をインストールする場合の指定はどうなるかって調べてた。
こんな感じでいいらしい。

Django>=1.2,<1.3

toxのdepsで決め打ちだと更新が面倒だし、こういう指定が便利だね。