読者です 読者をやめる 読者になる 読者になる

Travis CIでpython3.1が外されていた

bpmappersはbitbucket上で主に開発してるけど、githubにもpushしてTravis CIを使ってる。
最近ドキュメントだけ変更してpushしたらエラーがでてた。
コードは変更してないのになーと思ってTravis CIのログを見たらこんなメッセージが。

ERROR:   py31: InterpreterNotFound: python3.1

いつの間にかpython3.1が初期状態でインストールされなくなったみたい。
deadsnakesは有効なので、.travis.yamlファイルにインストールするようコマンドを書けば使える。

install:
    - sudo apt-get install -q python3.1-dev